During a security research I found an authenticated Stored XSS vulnerability. The name of the plugin is: WBW Currency Switcher for WooCommerce <= 1.6.6

Description

The plugin does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

POC

In the plugin's settings (WooCommerce > Settings > Currency > Frontend Switcher), 
tick "Enable switcher" and put the following payload in the "Panel header text" settings: 

<img src onerror=alert(/XSS/)>

Save the settings. The XSS will be triggered when viewing the settings page 
again, as well as in any frontend page   

Additional information

WPSCAN link: https://wpscan.com/vulnerability/e934af78-9dfd-4e14-853d-dc453de6e365

Plugin has more than 3,000+ active installations.