During a security research I found an authenticated Stored XSS vulnerability.

The name of the plugin is: Advanced Comment Form < 1.2.1

Description

The plugin does not sanitise and escape its settings, allowing high 
privilege users such as admin to perform cross-Site Scripting attacks 
even when the unfiltered_html capability is disallowed.

POC

The PoC will be displayed on September 29, 2022, 
to give users the time to update. 

Additional information

WPSCAN link: https://wpscan.com/vulnerability/cb6f4953-e68b-48f3-a821-a1d77e5476ef

Plugin has more than 6,000+ active installations.